Сен 26 2009

Vyatta. Начальная настройка.

После того, как мы установили Vyatta, в первую очередь необходимо настроить сеть и обеспечить удаленный доступ к системе.
Разработчики Vyatta очень хорошо поработали в плане доработки командной строки. Теперь для того что бы настраивать Vyatta, а вы помните, что Vyatta, создана на базе Debian Linux, совсем не нужно править конфигурационные файлы. Можно воспользоваться либо режимом configure командной строки либо вебинтерфейсом. В общем в этой статье, мы настроим сеть, включим ssh2 и вебинтерфейс. Первичная настройка делается с консоли.
Настроим сеть, для этого сначала необходимо просмотреть какие сетевые карты у нас имеются, делается это командой:

show interfaces

Если у вас несколько видов интерфейсов, а вы хотите увидеть только ethernet интерфейсы то команду можно выполнить с большим уточнением:

show interfaces ethernet

Так же, если вы забыли как правильно продолжать команду, то можно получить подсказку, нажав Tab.
Выполнив show interfaces, я у себя увидел:
vyatta11
На тестовой платформе у меня один интерфейс eth0, его и будем настраивать, я для этого сначала перейдем в режим настройки, выполнив команду:

configure

Vyatta перейдет в режим настроки, и пропишем адрес на интерфейс:

set interfaces ethernet eth0 address 192.168.0.252/24

и потом обязательно команду:

commit

commit обязательно нужен, что бы применить настройки.
Теперь выходим из режима настройки командой:

exit

И посмотрем какой эффект получился после наших настраиваний, командой:

show interfaces  ethernet eth0

И увидим:
vyatta12
команда отработала нормально. Для того, что бы сохранить изменения(что бы они остались после перезагрузки), нужно выполнить команду:

save

Но сейчас мы ее выполнять не будем, все равно еще настраивать роутинг и включать ssh и web интерфейс.
Поэтому продолжаем настройку, входим опять в режим настройки:

configure

И прописываем маршрут по умолчанию(default route):

set protocols static route 0.0.0.0/0 next-hop 192.168.0.15

и соответственно:

commit

И теперь выходим из режима настройки командой:

exit

И опять таки, проверяем наши настройки, а конкретно, посмотрим таблицу роутинга:

show ip route

и увидим:
vyatta13

В общем с тем, как работать с интерфейсами и менять статические маршруты мы разобрались, теперь нужно разабраться. как добавлять, удалять пользователей и с их правами доступа.
Переходим в режим настройки:

configure

И теперь добавим пользователя hilik с правми админа и с паролем hilik:

set system login user hilik level admin
set system login user hilik authentification plaintext-password hilik

Первая команда тут задает права пользователя, а вторая устанавливает пароль.
В случае, если вам, нужен read-only пользователь, то добавляется он так:

set system login user support level operator
set system login user support authentification plaintext-password support

И опять не забываем команду:

commit

И теперь мы переходим к настройке внешних доступов ssh2 и вебинтерфейса.
Начнем с ssh2:

set service ssh protocol-version v2
set service ssh port 22

и опять:

commit

Теперь к нашему серверу Vyatta можно подключаться по протоколу ssh2.
И переходим к запуску вебинтерфейса управления. Скажу сразу, я не приветствую использование вебинтерфейсов и если есть возможность пользуюсь командной строкой. Но настроить доступ мы настроим.
Переходим в режим настройки:

configure

и выполняем команду:

set service https

и выполняем команду:

commit

Vyatta сама сгенерирует сертификаты и запустить lighttpd сервер.
vyatta14

Теперь можно подключится с помощью браузера. Браузер естественно повозмущается, на не валидность сертификата, но добавив исключение мы увидим вебинтерфейс.
Выглядит вебинтерфейс так:
vyatta15
Авторизоваться в вебинтерфейсе может любой пользователь, кроме рута. Естественно у пользователя с правами operator будет заблокирована владка Configuration.
Выглядит панель управления так:
vyatta16
Теперь можно выполнить команду:

save

И переходить на нормальную, удаленную работу с маршрутизатором. Через ssh или через вебинтерфейс.
Первичная настройка окончена.

Добавить в закладки:

google.com bobrdobr.ru del.icio.us technorati.com linkstore.ru news2.ru rumarkz.ru memori.ru moemesto.ru

Украинская Баннерная Сеть