Окт 26 2009

Vyatta. Настройка OSPF.

OSPF — протокол динамической маршрутизации который используется внутри локальной сети или автономной системы для передачи маршрутизаторам внутренних маршрутов.
Для того, что бы разобраться с настройкой OSPF я создал небольшую тестовую площадку.
С одной стороны на сервере с адресом 192.168.1.1 стоит quagga.

Настройки у него такие:

router ospf
 redistribute static
 passive-interface default
 no passive-interface xl1
 network 192.168.1.0/24 area 0.0.0.0

Сервер с vyatta имеет адрес 192.168.1.12.
Настроим арию 0 — бекбон на vyatta. Для этого выполним команду:

configure
 set protocols ospf area 0 network 192.168.1.0/24

После того как мы выполним команду:

commit

Можно посмотреть видно ли второй маршрутизатор:

show ip ospf neighbor

Да второй маршрутизатор видно:

Neighbor ID Pri State           Dead Time Address         Interface            RXmtL RqstL DBsmL
91.202.72.129     1 Full/DR           35.748s 192.168.1.1     eth0:192.168.1.12        0     0     0

Теперь, поскольку Vyatta внешним интерфейсом eth1 смотрит в мир, я сделаю его пассивным.

set protocols ospf passive-interface eth1

и опять выполним

commit

Теперь определим, что будем анонсировать в арию:

set protocols ospf redistribute connected

И для тестов добавим, сеть 192.168.5.0/24, что бы увидеть ее

set interfaces ethernet eth0 address 192.168.5.1/24

и опять

commit

Теперь посмотрим на маршрутизаторе 192.168.1.1 c quaggой, какие сети анонсируются по OSPF:

show ip ospf route
============ OSPF network routing table ============
N    192.168.1.0/24        [10] area: 0.0.0.0
                           directly attached to xl1
 
============ OSPF router routing table =============
R    192.168.1.12          [10] area: 0.0.0.0, ASBR
                           via 192.168.1.12, xl1
 
============ OSPF external routing table ===========
N E2 89.252.34.0/24      [10/20] tag: 0
                           via 192.168.1.12, xl1
N E2 192.168.5.0/24        [10/20] tag: 0
                           via 192.168.1.12, xl1

То есть, помимо 192.168.5.0/24, мы видим сеть 89.252.34.0/24, которая подключена к внешнему интерфейсу eth1.

Итак, ospf работает, как и ожидалось. Теперь остается настроить фильтрацию анонсов. Мы исключим анонсы сети 89.252.34.0/24.
Для этого сначала создадим access-list:

set policy access-list 10 rule 1 action permit
set policy access-list 10 rule 1 source network 192.168.5.0
set policy access-list 10 rule 1 source inverse-mask 0.0.0.255
set policy access-list 10 rule 2 action deny
set policy access-list 10 rule 2 source any
commit

и теперь внесем его в настройки ospf:

 set protocols ospf access-list 10 export connected
commit

И теперь смотрим на втором маршрутизаторе анонсы:

show ip ospf route
============ OSPF network routing table ============
N    192.168.1.0/24        [10] area: 0.0.0.0
                           directly attached to xl1
 
============ OSPF router routing table =============
R    192.168.1.12          [10] area: 0.0.0.0, ASBR
                           via 192.168.1.12, xl1
 
============ OSPF external routing table ===========
N E2 192.168.5.0/24        [10/20] tag: 0
                           via 192.168.1.12, xl1

89.252.34.0/24 — замечательно отфильтровалось.

Настройка OSPF на этом окончена. Все что хотелось настроить — настроено и все получилось.

Добавить в закладки:

google.com bobrdobr.ru del.icio.us technorati.com linkstore.ru news2.ru rumarkz.ru memori.ru moemesto.ru

Украинская Баннерная Сеть