Июл 13 2009

Экономная схема построения QinQ

В статье Q-in-Q настройка в Cisco Catalyst 3750 я описывал схему построения туннеля 802.1q с использованием целых 4-х коммутаторов класом никак не ниже Cisco Catalyst 35XX серии. Не всегда приходится строить такие схемы для подключения сразу 10-ти и более бизнес клиентов. Иногда приходится строить тунель для 2-х, максимум 3-х клиентов с неясными перспективами на подключение новых клиентов. Поэтому приходится экономить, и тут можно съэкономить кардинально, убрав из этой классической схемы 2 свитча. Схема упростится за счет того, что мы с тегируемого порта свича, поставим кабель идущий в порт, находящийся в режиме dot1q-tunnel. Таким образом мы соорудим так называемый QinQ Loop. Схема коммутации будет выглядеть так:
qinq1

По данной схеме: Сервер подключен к первому порту Switch1, Gi1/0/1. Он находится в режиме транка и на нем разрешены вланы 11, 12,13, которые терменируются на сервере. Второй порт Gi1/0/2 находится в режиме транка и на него приходят все вланы выше перечисленные вланы. Он нужен для того что бы подать на третий порт Gi1/0/3 пакеты которые будут упакованы в dot1q-tunnel. Порт Gi1/0/3 соответственно находится в режиме QinQ и упаковывает все во влан 10. Как видно из схемы между этими портами просто стоит кабель эзернет. Обычная витая пара. Влан 10 через порт Gi1/0/28 через транспортную сеть подает пакеты в свитч Switch 2.
Настройки перечисленных портов Switch1.
Порт Gi1/0/1:

interface GigabitEthernet1/0/1
 description Server
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 11-13
 switchport mode trunk
 duplex full

Порт Gi1/0/2:

interface GigabitEthernet1/0/2
 description QinQLoopTrunk
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 11-13
 switchport mode trunk
 duplex full

Порт Gi1/0/3:

interface GigabitEthernet1/0/3
 description Q-IN-Q 
 switchport access vlan 10
 switchport mode dot1q-tunnel
 switchport nonegotiate
 no mdix auto
 no cdp enable
 spanning-tree bpdufilter enable
 spanning-tree bpduguard enable
!

Порт Gi1/0/28

interface GigabitEthernet1/0/28
 description ToSwitch2ViaTransport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10
 switchport mode trunk
!

На коммутаторе Switch2 вся конфигурация повторяется, за исключением того, что порта сервера не будет, зато будет 2 порта клиентов в режиме access. Итого конфигурация портов на Switch2 будет такая:
Порт Gi1/0/2 транк порт для QinQ Loop:

interface GigabitEthernet1/0/2
 description QinQLoopTrunk
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 11-13
 switchport mode trunk
 duplex full

Порт Gi1/0/3 QinQшный порт на Switch2:

interface GigabitEthernet1/0/3
 description Q-IN-Q 
 switchport access vlan 10
 switchport mode dot1q-tunnel
 switchport nonegotiate
 no mdix auto
 no cdp enable
 spanning-tree bpdufilter enable
 spanning-tree bpduguard enable
!

Gi1/0/28, порт с которого поступает трафик через транспортную сеть:

interface GigabitEthernet1/0/28
 description ToSwitch1ViaTransport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10
 switchport mode trunk
!

Настройка этих портов пока идентична настройке таких же портов на Switch1.
А теперь того, чего нет на Switch1, настройка клиентских портов:
Gi1/0/4 — первый клиент:

interface GigabitEthernet1/0/4
 description 'First'
 switchport access vlan 11
  switchport mode access
!

Gi1/0/5 — второй клиент:

interface GigabitEthernet1/0/5
 description 'Second'
 switchport access vlan 12
  switchport mode access
!

Gi1/0/6 — третий клиент:

interface GigabitEthernet1/0/6
 description 'Therd'
 switchport access vlan 13
  switchport mode access
!

На этом все. Настройки работают. Проверенно.

Добавить в закладки:

google.com bobrdobr.ru del.icio.us technorati.com linkstore.ru news2.ru rumarkz.ru memori.ru moemesto.ru
  • By nick, 27.01.2010 @ 00:15

    странно … но у меня ПОЧТИ все работает …
    Mac Address Table
    ——————————————-

    Vlan Mac Address Type Ports
    —- ———— ——— ——
    x 0002.4440.bdc8 DYNAMIC Fa0/27
    xxx 0002.4440.bdc8 DYNAMIC Fa0/35
    Total Mac Addresses for this criterion: 2

    такие маки не работают (Х — вилан УЖЕ с одним тагом, ХХХ — дважды тегированый )… но есть и такие что работают …. по теории так и дложно быть, а как оно заработало на практике ?

  • By dar, 08.06.2010 @ 09:51

    Пытаюсь кроме клиентских вланов передать ещё и управляющий, чтобы получить доступ к самому свичу2, но не получается.

    Клиенты работают, а свич не доступен. Если управляющий влан вывести в физический порт и подвесить на него какую-нибудь железку, тоже всё работает.

    Чего-то не хватает свичу, чтобы Interface VlanXX заработал полноценно через q-in-q.

  • By admin, 08.06.2010 @ 10:54

    У меня через qinq работает несколько ТП, другой связи с ними нет. IP адрес на влане есть и все нормально, он доступен по этому влану. Должно работать. Возможно дело в прошивке?

  • By dar, 09.06.2010 @ 15:51

    Возможно, дело в mtu. У меня везде 1500. Рекомендованное 1504 ситуацию не улучшило, а вот при установке 1546 (максимум для 3550 на которых я всё и ковыряю) по крайней мере в sh arp свич стал видеть роутер.

    Пингов пока ещё нет, ибо не на всём участке сети от свича до роутера mtu увеличен. Ночью ребутну свич, который в ядре сидит, завтра перепроверю стало ли легче.

  • By elephant, 11.06.2010 @ 11:43

    Спасибо .

    Неплохо б бьіло на картинке портьі подписать, соответственно тексту, для лучшего восприятия.

  • By akula, 22.07.2010 @ 10:57

    dar, 08.06.2010 @ 09:51

    Пытаюсь кроме клиентских вланов передать ещё и управляющий, чтобы получить доступ к самому свичу2, но не получается.

    такая же ситуация, увеличение mtu не помогает

Other Links to this Post


Украинская Баннерная Сеть